Critical GIS



WHAT IS GIS?

CAPTURE STORE QUERY ANALYSE VISUALIZE



WHAT WE WILL LEARN

Data Collection,
Manipulation &

@ Cartography &
Visualization
Management

Spatial Analysis Statistical & Modeling




GEOGRAPHICAL REPRESENTATION

COGNITIVE MAPPING AND MENTAL
MODEL

CARTOGRAPHY IS A SOCIAL
CONSTRUCT

THEMATIC MAPPING



Measuring the Earth

Topographic
Surface

* Geodesy

* The Earth has an oblate spheroid
shape, which is complex to model
accurately. H

* Simplifications h

* We use an ellipsoid as a more
practical and manageable
representation of the Earth's surface.

Ellipsoid

Geoid
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Plbtemy - Geographia
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Latitude and Longitude

Latitude Longitude
90°N
* Measures north to south
* 90°in each hemisphere 45°N
* |Increases as you go north in the northern
hemisphere
. Ihnecnrqeiggﬁzfes you go south in the southern 0° Equator (W] E )
* Zerois Equator
Longitude(Meridians) 45°S
* Measures east to west
* 180°in each hemisphere 90°5
* Increases as you go east in the eastern Latitude varies from 0° Longitude varies
hemisphere at the equator to 90° from 0° at
, North and South at the Greenwich to 180°

e Zerois Prime Meridian
1 ° Degree = 60 Minutes = 3,600 Seconds



Time Zones
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Islamic Medieval
Cartography

Al-ldrisi




MAP PROJECTIONS

* Map projections allow us to view
the 3D Earth on a 2D surface

* Earth is mathematically projected
to a surface that can be made flat

* We now make measurements in
distance or length units as
opposed to degrees

* A Cartesian coordinate system

* We call these surfaces Map
Projections
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Geographic vs. Projected Coordinate Systems




MAP DISTORSIONS
O 0 O

SHAPE AREA DISTANCE DIRECTION



* https://www.thetruesize.com/




DATA?






Marco Polo, 24 years (1271-1295)
24,000 km
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Ibn Battuta, 29 years (1325-1354)
117,000 km

Zheng He, 28 years (1405-
1433), 50,000 km

ATLANTIC
OCEAN

Tangier,
Marrakech

i~

Oualdta,

Bamako,

/

Routes of Ibn Battutah
G 1325-27
G 1330-32

Note: Dashed lines indicate routes Ibn Battutah
may have followed
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What count as Data?



Non-Spatial Data in GIS

V Attributes = non-spatial characteristics associated with spatial data

Nominal = A unique identifier or unique types
Categorical

‘|||l Ordinal = Ranked data

Interval = Difference between numbers is significant, but no fixed non-

EIE arbitrary zero point

Numeric

E Ratio = Difference between numbers is significant, and there is a fixed

non-arbitrary zero value



Nominal Data
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Surface Temperature on Friday 21 Feb at 11am F‘I{T

Freezing level contours

Interval Data
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*Includes four provinces, federal capital,
and Azad Kashmir. Data is not available
for Gilgit-Baltistan as of July 2021

Urbanization Rate (2017)

2021 Division
Borders in use

85%+

65% - 85%
50% - 65%
40% - 50%
30% - 40%
20% - 30%
10% - 20%

Ratio Data S RS

Total: 36.07%*

Punjab: 36.86%
Sindh: 51.89%
Khyber Pakhtunkhwa: 16.55%
Balochistan: 27.62%
Azad Jammu & Kashmir: 17.37%
Islamabad Capital Territory: 50.37%

Top Five Bottom Five
Karachi Division: 92.88% Bannu Division: 5.41%
Lahore Division: 69.40% Malakand Division: 10.43%
Islamabad Capital Territory: 50.37% Hazara Division: 10.75%
Rawalpindi Division: 41.32% Loralai Division: 12.40%
‘ ) o o ision: 13,589
Source: 2017 Pakistan Faisalabad Division: 36.87% Zhob Division: 13.58%

Population &
Housing Census
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VECTOR DATA?

u

POINT LINE POLYGON




1. Manually Adding Points from QGis B PR M@ ® e a0
B@V. 2BV 4/ 8.
Create a New Point Layer B A

Layers = 3 §

1. Open QGIS and go to Layer > Create Layer > New Shapefile Layer. « @ = ¥ & - @ @ [1

v # 2pointsdata

2. In the dialog:

1. Set File Name and Save location.

2. Choose Geometry Type as Point. . i

3. Set CRS (Coordinate Reference System) (e.g., WGS 84 / e
EPSG:4326). e

4. Add any necessary attributes (e.g., "Name", "ID"). —

5. Click OK. s 0

Start Editing the Layer
1. In the Layers Panel, select your new point layer.

2. Click on the Toggle Editing button (pencilicon) in the Toolbar.

3. Click on the Add Point Feature tool (looks like a point).

4. Click anywhere on the map where you want to add a point.

5. Click Save Edits and Toggle Editing off.
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Export as CSV

Select Your Layer In the Layers Panel

* right-click your point layer.

e Click Export > Save Features As....

Configure Export Settings In the Save Vector Layer
* Format: Choose Comma Separated Value (CSV).

* File Name: Click Browse and choose a location to save your
CSVW.
* Layer Options:
 Geometry: Choose Point coordinates.

* Make sure Geometry is set to "AS_XY" (this ensures
latitude/longitude are included).

* CRS: Select WGS 84 (EPSG:4326) for standard lat/lon
coordinates.

* Encoding: Keep as UTF-8 (to avoid character issues).

Why = Easier to deal with CSV than shapefile +
remote sensing imagery

N

Format Comma Separated Value [CSV]
File name  |points
Layer name

CRS EPSG:4326 - WGS 84

» Extent (current: none)

w Layer Options

CREATE_CSVT NO v
GEOMETRY AS_XY v
LINEFORMAT <Default> v
SEPARATOR COMMA v

STRING_QUOTING | IF_AMBIGUOUS

WRITE_BOM NO

w Custom Options

Data source

Layer

V| Add saved file to map OK

Cancel

Help



2. Data from
Google Maps

* Open Google Maps
* Right Click

* Careful Google maps
Is lat long

 Paste in csv file
* Cleanup

v 7 Google Maps X e
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Load CSV into QGIS

1. Open QGIS and go to Layer > Add Layer > Add
Delimited Text Layer...

2. Click "..." next to File Name and select your CSV file. ADD DELIMITED TEXT LAYER

3. In the File Format section, select:

Ty . e\

1 . CSV (Comma-separated) (OI’ adjust if USing (2 Data Source Manager | Delimited Text = m]
another de“mitel’). i Browser * File name
CROR Layer name Encoding | UTF-8
4. In Geometry Definition: e v File Format
1. Select Point Coordinates. my o @) CSV (comma separated values)
. H "I!' Mesh eqular expression delimiter
2. Set X Field to long (Longitude). . Feadar expresson ceimt

; Point Cloud Custom delimiters

3. SetY Field to lat (Latitude).

,ﬂ TD;'lmitEd w Record and Fields Options

5‘ Choose the Coordinate Refe rence SVStem (CRS): Number of header lines to discard 0 - Decimal separator is comma

1. If coordinates are in WGS 84, select EPSG:4326. | Firt record has fled names Trim fieds

. . V' Detect field types Discard empty fields

2. Ifusing another CRS, choose accordingly. 7, spatialite Gustom boolean fiterals

6. Cl_le Add > Close. + PostgreSQL True False
MS sQL

Save as a Shapefile B <5y

. . . ¥ Orece @) Point coordinates Xfield ~ | Zfield v
1. Right-click the CSV layer in Layers Panel. WA i e - o 1 M .

. DMS coordinates
2 . C l.l C k EXpO rt-> save Featu res AS PN 3 AP HANA No geometry (attribute only table) Geometry CRS | EPSG:4326 - WGS 84 v | &

@; WMS/WMTS

3. Choose ESRI Shapefile (or another format). v Layer Settings

. WFS/0GC
Q7 AP -

4. Select the appropriate CRS and location, then save. P = e b

Please select an input file




Geolocated Photos

Apple

1. Enable Location Services for Camera

1.

2.
3.
4.

Go to Settings > Privacy & Security > Location
Services

Ensure Location Services is ON
Scroll down and select Camera
Choose While Using the App or Always

2. Verify Geotagging in Photos

1.
2.
3.

Open Camera and take a picture
Open Photos app, select the image, and swipe up
If location appears, geotagging is active

3. Troubleshooting

1.

2.

If no location is saved, restart the phone and retake
the photo

Ensure Airplane Mode is OFF (GPS needs
connectivity)

Android

1. Enable Location Services
1. Goto Settings > Location
2. Toggle Use Location ON

2. Enable Location for Camera
1. Openthe Camera app
2. Goto Settings (Gearlcon)

3. Look for Save Location / Location Tags / Geotagging
(varies by brand)

4. Turnit ON

3. Verify Geotagging in Photos
1. Take a picture
2. Open Google Photos or Gallery
3. Swipe up onthe photo and check if a map/location appear



3.

Geolocated
Photos

\— P BN AN PN

- (2 Vector Creation - Import Geotagged Photos

Parameters Log

Input folder

Scan recursively

Photos [optional]

[Create temporary layer]

V| Open output file after running algorithm
Invalid photos table [optional]

[Skip output]

Open output file after running algorithm

0%

Advanced ~ | Run as Batch Process...

| ctntt ttmminn | L9 Processi

X

Import geotagged photos

Creates a point layer corresponding to the
geotagged locations from JPEG or HEIF/HEIC
images from a source folder. Optionally the folder
can be recursively scanned.

The point layer will contain a single PointZ feature
per input file from which the geotags could be
read. Any altitude information from the geotags
will be used to set the point's Z value.

Optionally, a table of unreadable or non-
geotagged photos can also be created.

Cancel

Run Close Help

=



How to preserve geolocation data?

* WhatsApp/Telegram etc removes EXIF metadata.

* You can still share geolocated images using these methods:
* Method 1: Send as a "Document” (Keeps GPS Data)
1.0pen WhatsApp and go to the chat.

2.Tap the paperclip (Android) or "+" icon (iPhone).

3.Select Document > Browse Other Docs.

4.Navigate to your photo folder and select the image.

5.S5end the photo without compression—the metadata, including
location, remains intact.



4. Satellite Imagery

* How to Get an API| Key?

1.Sign up at
https://browser.dataspa
ce.copernicus.eu/

2.Navigate to Dashboard
> Access &
Authentication.

3.Create a new API Key
under OAuth Clients.

4.Use the key in your API
requests or
applications.

OpemiCUS EN v  Davide Giacomo... v Please zoom in or search for a location of interest
BROWSER

VISUALISE SEARCH

)ATE: SINGLE ﬂ & A

< YYYY-MM-DD >

Find products for current view

INethenlands]

famsterdamyl

'ONFIGURATIONS: A

Jefault v

JATA COLLECTIONS: * = X A
Sentinel-2 voi

Sentinel-2 L1C i
Sentinel-2 L2A v4 i

Qesa About Support

Edl |eaflet | © OpenStreetMab contributors - Disclaimer. © Sentinel Hub

] Copericus


https://browser.dataspace.copernicus.eu/
https://browser.dataspace.copernicus.eu/

Adding Fields

Create layer and add fields

Make sure to define the correct

type

Data Description

Type

Short | Integer values between -32,768
Integer and 32,767

Long Integer values between -
Integer |2,147,483,648 and 2,147,483,647

Float | Decimal values with 1-6 decimal

places
Double | Decimal values with more the 6
decimal places
Text Text strings
Date Data info (mm/dd/yyyy)

() New Shapefile Layer

File name
File encoding

Geometry type

Additional dimensions

New Field

Name ||

Type abc Text (string)

Length |80 Precision
Fields List
Name Type
d Integ
category String

example.shp

UTF-8

2" Point

@) None

EPSG:4326 - WGS 84

Add to Fields List

Length P

10
80

recision

Z (+ M values)

OK

e
A
\4
5 Remove Field
Cancel Help



Add Geometric Fields

Use Add Geometry Attributes Tool

Spatial Data Type

Geometry?

points Xy coordinates

lines

Length bearing

polygons Area/perimeter/centroid

Q@ Vector Geometry - Add Geometry Attributes

Parameters Log

Input layer

Selected features only

Calculate using

Layer CRS
Added geom info

[Create temporary layer]

V| Open output file after running algorithm

Advanced ~ | |Run as Batch Process...

- €9 % =

0%

Add geometry attributes

This algorithm computes geometric properties of
the features in a vector layer. It generates a new
vector layer with the same content as the input
one, but with additional attributes in its attributes
table, containing geometric measurements.

Depending on the geometry type of the vector

layer, the attributes added to the table will be
different.

Cancel

Run Close Help



Select by Location

Select based on
spatial relationships
to other geographic
features

Parameters Log

Select features from

Where the features (geometric predicate)

V| intersect touch
contain overlap
disjoint are within
equal Cross

By comparing to the features from

Selected features only

Modify current selection by

creating new selection

Advanced ~ | |Run as Batch Process...

ML ¢ BN

0%

Select by location
This algorithm creates a selection in a vector
layer. The criteria for selecting features is based

on the spatial relationship between each feature
and the features in an additional layer.

Cancel

Run Close Help
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Q pak_admbnda_adm3_wfp_20220909 — Features Total: 577, Filtered: 577, Selected: 92 = 0 X

JEBR B DENGYEYP Li2E B &5

8; Expression

A' Shape_Leng  0.37180462695
Shape_Area  0.006598530589
ADM3_EN  Sukkur
ADM3_PCODE PK72305
ADM3_REF L

] Sukkur

U] New Sukkur
U] Saeedabad
L] Mehrab Pur

L] Sobho Dero ADMIALTLEN VL)

" Dol ADMBALT2EN (11

L] Kot Dij ADM2EN  Suklur

 Lakni ADM2_PCODE PK723

U| Gambat ADMLEN ~ Sindh

[ Larkana ADM1_PCODE  PK7

U] Tando Adam ADMOEN  Pakistan

D Bhiria ADMO0_PCODE PK

U] Thari Meer Wah date 20220502 \/
L Jiwani validon - 2022:09-09 v
U] Nawabshah validTo NULL v
Ul Hala

O Bagrani

O Kingri v

P B1/s L] @ P
‘ Show Al Features _




OF SYMBOLS AND
REPRESENTATIONS
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Qutline of Hereford Mappa Mundi c. 1285, showing modern countries
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